[chimera-dev] [stevel at blake.3dem.bioch.bcm.tmc.edu: Re: Chimera at NCMI]

Thomas Goddard goddard at cgl.ucsf.EDU
Mon Nov 25 11:55:37 PST 2002

------- Start of forwarded message -------
Date: Mon, 25 Nov 2002 13:37:43 -0600 (CST)
From: Steven Ludtke <stevel at blake.3dem.bioch.bcm.tmc.edu>
X-X-Sender: stevel at id.3dem.bioch.bcm.tmc.edu
Reply-To: sludtke at bcm.tmc.edu
To: Thomas Goddard <goddard at cgl.ucsf.EDU>
Subject: Re: Chimera at NCMI
In-Reply-To: <200211251932.gAPJWPdN690278 at adenine.cgl.ucsf.edu>
Content-Type: TEXT/PLAIN; charset=US-ASCII
X-Filter-Version: 1.9 (cgl.ucsf.edu)

On Mon, 25 Nov 2002, Thomas Goddard wrote:

>   I don't understand why the installer failed when installing in
> /home/stevel/chimera.  I just tried the linux installer from the web
> in my home directory and it worked.  If it works as root for you, that seems
> to indicate it is a permissions problem.  Can you send me the permissions
> on your home directory, "ls -l /home/stevel"?  It should also work if
> you create the chimera directory first.  I tested that and it also
> worked.  The installer no longer removes an old Chimera.  If you try
> to install where a Chimera already exists, it will ask you to move it
> or delete it yourself (from another shell) before proceeding.

Found the problem. Stupidity on my part (as ususal). One machine uses 
/homes/stevel, the other uses /home/stevel, and I got them backwards.

>   I agree that the web page should say next to the download link
> the date and version of the last release.  Currently you have to
> follow the release notes link from the home page to check this.
> If you already have Chimera running, the Help/Software Updates
> menu entry will tell you if you have the most recent version.

Good tip.

>   The Puppet extension for remote controlling chimera uses the Tcl socket
> command to listen for socket connections.  When a new connection is made
> a Tcl event appears in the event loop.  I couldn't get that behaviour with
> the Python socket module, and I didn't try a separate thread.  Using Tcl
> socket worked ok, but I don't know if it handles unix domain sockets.
> I was using INET domain sockets and Puppet just checks that the connection
> is being made from the machine chimera is running on.  That is obviously
> inadequate security on a multi-user machine.  The Puppet extension is not
> distributed with Chimera because of this security problem.  I think I gave
> you a copy several months ago.  If you can't find it, I can provide you
> another copy of the Puppet Python code.

Yeah, I've still got it. I sort of wanted to avoid doing any explicit TCL 
stuff. I hadn't checked to see how you handle that.  Anyway, that answers 
my question

Thx, and sorry to waste your time on the installer thing...

- -- 
- ----------------------------------------------------------------------------
Steven Ludtke, PhD              |        Baylor College of Medicine
sludtke at bcm.tmc.edu             |               Co-Director
stevel at alumni.caltech.edu       | National Center For Macromolecular Imaging 
V: (713)798-6989                |    Dept of Biochemistry and Mol. Biol.
instant messenger: sludtke42    |            * Those who do ARE *
http://ncmi.bcm.tmc.edu/~stevel |           The converse also holds
------- End of forwarded message -------

More information about the Chimera-dev mailing list